Data Processing Delays - Sleep Data Affected
Incident Report for Eight Sleep
Resolved
This incident has been resolved.
Posted Mar 12, 2021 - 11:13 EST
Identified
Our data processing infrastructure is running behind. No data has been lost and your data will be available soon.
Posted Mar 12, 2021 - 09:03 EST
This incident affected: Data processing.