Data processing delay affecting some of our users
Incident Report for Eight
Resolved
This incident has been resolved.
Posted about 2 years ago. Mar 13, 2017 - 11:18 UTC
Investigating
We are currently investigating this issue.
Posted about 2 years ago. Mar 12, 2017 - 13:23 UTC