Data Processing Delays - AWS Infrastructure Degraded

Incident Report for Eight Sleep

Resolved

All systems have recovered and are now operating normally.
Posted Oct 21, 2025 - 02:04 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 01:56 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 01:55 EDT

Update

All app features have recovered. We are still monitoring some data processing lag that is impacting a small percentage of customers.
Posted Oct 20, 2025 - 23:53 EDT

Update

AWS Services are slowly coming back online. Some Eight Sleep devices and accounts remain affected.
Posted Oct 20, 2025 - 18:17 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 18:14 EDT

Update

A global AWS outage affecting many companies is causing intermittent disruptions to Eight Sleep services today. This is an issue with our cloud provider (AWS), it’s not caused by your Wi-Fi or by your Pod.

Until this is resolved by AWS, some sleep reports and morning recaps may be delayed and will update automatically once processing is restored. We’re monitoring this closely and will post live updates on this service status page.

We’re sorry for the inconvenience this has caused to your sleep.
Posted Oct 20, 2025 - 14:49 EDT

Update

Service interruption update — AWS global outage

A global AWS outage affecting many companies caused intermittent disruptions to Eight Sleep services today. Between 07:00–09:00 UTC some devices & control features were unreachable; select features continued to be degraded 09:00–11:00 UTC. AWS is still working on fully recovering their service levels, which Eight Sleep depends on.

We apologize for the disruption this has caused to your sleep.
Posted Oct 20, 2025 - 13:23 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 06:57 EDT

Monitoring

AWS is reporting recovery across services impacted by us-east-1 outage. We're seeing recovery across services, but data processing times will be increased as systems come back online.
Posted Oct 20, 2025 - 05:46 EDT
This incident affected: API, Data processing, Alarms, Smart-temp and AWS (AWS route53, AWS dynamodb-us-east-1, AWS elb-us-east-1, AWS ec2-us-east-1, AWS kinesis-us-east-1).